and (AutoLISP)

Returns the logical AND of the supplied arguments

Supported Platforms: Windows and Mac OS

Signature

(and [expr ...])
expr

Type: Symbol, Integer, Real, String, T, or nil

Any expression.

Return Values

Type: T or nil

nil, if any of the expressions evaluate to nil; otherwise T. If and is issued without arguments, it returns T.

Examples

(setq a 103 b nil c "string")
"string"

(and 1.4 a c)
T

(and 1.4 a b c)
nil