The following table provides summary descriptions of the AutoLISP equality and conditional functions.
Equality and conditional functions |
|
---|---|
Function |
Description |
Returns T if all arguments are numerically equal, and returns nil otherwise |
|
Returns T if the arguments are not numerically equal, and nil if the arguments are numerically equal |
|
Returns T if each argument is numerically less than the argument to its right, and returns nil otherwise |
|
Returns T if each argument is numerically less than or equal to the argument to its right, and returns nil otherwise |
|
Returns T if each argument is numerically greater than the argument to its right, and returns nil otherwise |
|
Returns T if each argument is numerically greater than or equal to the argument to its right, and returns nil otherwise |
|
Returns the logical AND of a list of expressions |
|
Serves as a general bitwise Boolean function |
|
Serves as the primary conditional function for AutoLISP |
|
Determines whether two expressions are identical |
|
Determines whether two expressions are equal |
|
Conditionally evaluates expressions |
|
Returns the logical OR of a list of expressions |
|
Evaluates each expression a specified number of times, and returns the value of the last expression |
|
Evaluates a test expression, and if it is not nil, evaluates other expressions; repeats this process until the test expression evaluates to nil |