The following table provides summary descriptions of the AutoLISP symbol table and dictionary-handling functions.
Symbol table and dictionary-handling functions |
|
---|---|
Function |
Description |
Adds a non-graphical object to the specified dictionary |
|
Finds the next item in a dictionary |
|
Removes an entry from the specified dictionary |
|
Renames a dictionary entry |
|
Searches a dictionary for an item |
|
Returns a list of all paper space layouts in the current drawing |
|
Returns the entity name of the current drawing's named object dictionary, which is the root of all non-graphical objects in the drawing |
|
Establishes a view for a specified viewport |
|
Checks the symbol table name for valid characters |
|
Finds the next item in a symbol table |
|
Returns the entity name of a specified symbol table entry |
|
Searches a symbol table for a symbol name |
|
Erases AutoLISP data from a drawing dictionary Note: Extended AutoLISP extension: requires
vl-load-com
|
|
Retrieves AutoLISP data from a drawing dictionary Note: Extended AutoLISP extension: requires
vl-load-com
|
|
Lists AutoLISP data in a drawing dictionary Note: Extended AutoLISP extension: requires
vl-load-com
|
|
Stores AutoLISP data in a drawing dictionary Note: Extended AutoLISP extension: requires
vl-load-com
|
|
Determines whether data can be saved over a session boundary Note: Extended AutoLISP extension: requires
vl-load-com
|