The following table provides summary descriptions of the AutoLISP geometric functions.
Geometric functions |
|
---|---|
Function |
Description |
Returns an angle in radians of a line defined by two endpoints |
|
Returns the 3D distance between two points |
|
Finds the intersection of two lines |
|
Returns a 3D point that is the result of applying an Object Snap mode to a specified point |
|
Returns the UCS 3D point at a specified angle and distance from a point |
|
Measures a specified text object, and returns the diagonal coordinates of a box that encloses the text |