append (AutoLISP)

Takes any number of lists and appends them together as one list

Supported Platforms: Windows and Mac OS

Signature

(append [list ...])
list

Type: List

A list.

Return Values

Type: List or nil

A list with all arguments appended to the original. If no arguments are supplied, append returns nil.

Examples

(append '(a b) '(c d))
(A B C D)

(append '((a)(b)) '((c)(d)))
((A) (B) (C) (D))