The following table provides summary descriptions of the AutoLISP list manipulation functions.
List manipulation functions |
|
---|---|
Function |
Description |
Sorts a list of strings by alphabetical order |
|
Takes any number of lists and runs them together as one list |
|
Searches an association list for an element and returns that association list entry |
|
Returns the third element of a list |
|
Returns the second element of a list |
|
Returns the first element of a list |
|
Returns the specified list, except for the first element of the list |
|
The basic list constructor |
|
Evaluates expressions for all members of a list |
|
Returns the last element in a list |
|
Returns an integer indicating the number of elements in a list |
|
Takes any number of expressions and combines them into one list |
|
Verifies that an item is a list |
|
Returns a list of the result of executing a function with the individual elements of a list or lists supplied as arguments to the function |
|
Searches a list for an occurrence of an expression and returns the remainder of the list, starting with the first occurrence of the expression |
|
Returns the nth element of a list |
|
Returns a list with its elements reversed |
|
Searches a list for an old item and returns a copy of the list with a new item substituted in place of every occurrence of the old item |
|
Determines whether or not a list is nil |
|
Checks whether the predicate is true for every element combination |
|
Constructs and returns a list |
|
Combines the Unicode characters associated with a list of integers into a string |
|
Calculates list length of a true list |
|
Determines whether the predicate is true for one of the list members |
|
Determines whether the predicate is nil for one of the list members |
|
Returns the index of the specified list item |
|
Removes elements from a list |
|
Returns all elements of the supplied list that fail the test function |
|
Returns all elements of the supplied list that pass the test function |
|
Checks whether the predicate is not nil for one element combination |
|
Sorts the elements in a list according to a given compare function |
|
Sorts the elements in a list according to a given compare function, and returns the element index numbers |
|
Converts a string into a list of Unicode character codes |