The following table provides summary descriptions of the AutoLISP error-handling functions.
Error-handling functions |
|
---|---|
Function |
Description |
A user-definable error-handling function |
|
Error-handling function that ends the previous call to *push-error-using-command* or *push-error-using-stack* |
|
Error-handling function that indicates the use of the command function within a custom *error* handler |
|
Error-handling function that indicates the use of variables from the AutoLISP stack within a custom *error* handler |
|
Displays an alert dialog box with the error or warning message passed as a string |
|
Forces the current application to quit |
|
Forces the current application to quit |
|
Passes a list of arguments to a specified function and traps any exceptions |
|
Returns a string from an error object |
|
Determines whether an argument is an error object returned from vl-catch-all-apply |