length (AutoLISP)

Returns an integer indicating the number of elements in a list

Supported Platforms: Windows and Mac OS

Signature

(length lst)
lst

Type: List

An empty list or a list with one or more elements.

Return Values

Type: Integer

A numeric value.

Examples

(length '(a b c d))
4

(length '(a b (c d)))
3

(length '())
0