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Blank white page when accessing Autodesk Account portal

Technical Support

Issue:

When opening Autodesk Account portal, it is showing white blank page. 

 

white blank page. 

 

white blank page. 

Causes:

  • Unsupported Browser.

  • The account portal no longer supports the Russian language.

  • Autodesk's Terms and Conditions haven't been accepted.

 

Solution:

Change Default browser to Chrome

  1. On your computer, click the Start menu .
  2. Click "Settings".
  3. Open your default apps.
  4. At the bottom, under "Web browser", click your current browser(typically Microsoft Edge).
  5. In the "Choose an app" window, click Google Chrome.

Change Language setting to non-Russian

  1. Go to My profile and settings in your Autodesk account.
  2. Choose the "Settings" section in the left navigation pane
  3. Update the language to a language other than Russian.

Accept the Terms and Conditions

  1. Browse to accounts.autodesk.com in a separate tab of the browser.
  2. Since the account is already logged in to autodesk.com, accounts.autodesk.com will identify the account and prompt acceptance of the Terms and Conditions.

Products:

All Cloud and Desktop Products;

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