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DWG files unexpectedly become read-only and cannot be saved in AutoCAD or Civil 3D

Technical Support

Issue:

Users reported that when saving a drawing file in AutoCAD (almost exclusively to a network location), the file suddenly becomes read-only and cannot be saved. A a message appears similar to one of the following:

AutoCAD Message

Unable to save to drawing <path>\<drawingname>.dwg as it is being accessed by another session. Drawing saved to <path>\<filename>.tmp
AutoCAD Message - Unable to save to drawing

 

AutoCAD Message

Drawing file is write protected
 
AutoCAD Message Drawing file is write protected. 


The issue may occur with:

  • Single userA drawing is opened by one person. Saving suddenly shows the file as "read-only" and displays the error.

  • Multiple users: Two people open a drawing, one after the other. The second person does not receive the prompt that it is already in use, The drawing is "read-only" when the first person attempts to save the file, and the error is displayed. The second person is allowed to work on the drawing as usual because that session of AutoCAD has taken over read-write access to the file.

  • Unsupported non-Microsoft servers such as Google Drive, Egnyte, Lucid Link, etc. (see Support for Non-Microsoft Networks). 

 
 

Causes:

When AutoCAD saves a drawing (DWG), it writes the drawing to a temp (TMP) file, the newest save becomes the backup (BAK) file, then the TMP becomes the active DWG (see AutoCAD file save process for more detailed information on the process). In some instances, the last step fails.

Common causes for this are:

  • Unsupported network server devices: Network attached storage (NAS) device or storage area network (SAN) device.
  • Distributed File System (DFS): A DFS allows system administrators to make it easier for users to access and manage files that are physically distributed across a network. With a DFS, files distributed across multiple servers can appear to users as if they reside in one place on the network.
  • Mirrored file servers: Multiple server systems present the same files and different locations.
  • Insufficient Windows profile permissions.
  • Outdated or corrupted 3rd party software. 
  • Network performance issues:
    • Missing trusted file location and supported search path locations.
    • Synchronizing time between server and workstation.
    • Networks saturation/Excess server workload.
    • Defender Antivirus outbound rule missing.
    • Missing registry entry for network and cloud-enabling.
    • Virus protection on the client or server.
    • "Misbehaving" network drivers on the client or on the server.
    • Offline File syncing issues between the client system and the server.
    • Cloud storage solutions (DropBox, Google Drive, OneDrive, etc.) synchronize the folder where the drawings are stored on the local machine.

Solution:

Update, upgrade or reinstall AutoCAD

Configuration and settings within AutoCAD
  • Define the default location for BAK files to a local path. Enter MOVEBAK on the command line and navigate to the desired location.
  • Disable saving a backup file. Enter ISAVEBAK on the command line and change the value to 0 (zero). 
  • Stop appended saves and make sure that the full file saved each time. Enter ISAVEPERCENT on the command line and set the value to 0 (zero). 
  • Turn off registered app loading for custom objects.  Enter DEMANDLOAD on the command line and set the value to 0 (zero). 
Configuration and settings on the system
  • Add working path locations:
    1. In AutoCAD or Civil 3D, on the command line, type OPTIONS and hit 'Enter'.
    2. In the 'Files' tab select the '+' for 'Supported File Search Path' and 'Trusted File Locations' and click 'Add' then 'Browse'.
    3. Add in the location of the server, network, or cloud working folder file path for example, 'x:\servername....'.
    4. Then click 'Apply' and then 'OK' to close.
  • Files permissions:
    1. Check that correct permissions are set on DWG and BAK files, and hidden DWL and DWL2 files.
    2. Confirm that full read-write-modify permissions are on the folder location being saved to.
  • Files stored on inaccessible locations such as opening the DWG directly from and email or a disk (CD or DVD) that do not allow saving back to that source.
  • Rebuild the user profile for Windows.
  • For VPN, work with local data to pinpoint if the issue is related to the connection. 
    Configuration and settings on the network server
    • Bypass DFS shares by creating a mapped network drive directly to the UNC path of the folder where the drawing files are stored.
    • Check that mapped drives are not timing out (see Mapped Drive Connection to Network Share May Be Lost (Microsoft)).
    • Check if mapped drives are available.
      1. Press WINDOWS+R on the keyboard to bring up the Run window, enter REGEDIT, and click OK.
      2. Navigate to: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System.
      3. Right-click System and choose New > DWORD value.
      4. Type EnableLinkedConnections and press Enter.
      5. Double-click (or right-click > Modify) on EnableLinkedConnections.
      6. In the Value data field, type 1 and then click OK.
      7. Close the Registry Editor and restart the computer.
    • Check latency or lag time between AutoCAD and the server. Workstations may not be getting cues from the server about file locks at the right time.
      • Test saving and resaving to the local drive and then to a share on another workstation to pinpoint the problem network location.
      • Check the network adapter settings on all Ethernet ports and make sure they are not on auto-negotiation. If possible, they should be set to the speed of the network at full duplex (see "Configuring Windows 10 for Wired Publicly Accessible Network Ports" by PittNet Wired).
      • There could also be a conflict or bad synchronization time between the server and the workstation. Server time stamp settings should be checked to confirm proper functionality.
      Cloud storage applications and drives
      • Disable any storage applications and drives or wait until the folder/drive is synchronized with the cloud and then try opening/saving again.
      • Set the cloud provider's settings to always keep a local copy of the files on the workstation (disable files-on-demand, choose 'offline' setting, etc.).
      • If the cloud provider has an option to prompt the user for backup synchronization, disable that option.

      Disable processes

      • Disable offline files:
        1. Search for Control Panel > Sync Center > Manage offline files.
        2. Click Disable offline files and then click OK.
      • Turn off file indexing on the folder where DWG files are stored:
        1. Right-click the folder > Properties > General > Advanced.
        2. Turn off Allow files in the folder to have contents indexed in addition to file properties.
        3. Click OK.
      • Disable antivirus software. If this eliminates the problem:

      Work arounds

      • Attempt saving a second time after waiting a few seconds or attempt SAVEAS and overwrite the original drawing.
      • Use SAVEAS to save the file under a new name and then, within the operating system, rename/replace the original drawing.
      • Prevent the computer from going to sleep.
      • Reboot the network server (IT assistance may be required).
      • Delete all temporary files (see How to delete temporary files in Windows).
      • Test using an out-of-the-box profile (See How to reset Civil 3D to defaultHow to reset AutoCAD to defaults).
      • Sign in to another system and test saving in AutoCAD and have someone else sign in to the same computer and test AutoCAD.

         

          Products:

          AutoCAD for Mac; AutoCAD LT for Mac; AutoCAD Products;

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