Issue:
Users reported that when saving a drawing file in AutoCAD (almost exclusively to a network location), the file suddenly becomes read-only with a message appearing similar to one of the following:
AutoCAD Message
AutoCAD Message
The issue may occur with:
Single user: A drawing is opened by one person. Saving suddenly shows the file as "read-only" with the preceding error.
Multiple users: One person opens a drawing. Another person opens the same file and does not receive the prompt that the drawing is already in use. When the first person goes to save, it is "read-only" with the preceding error. The second person can work on the drawing as expected as that session of AutoCAD has taken over read-write access to the file.
Unsupported servers (non-Microsoft Servers such as Google Drive, Egnyte, Lucid Link, etc.).
Causes:
Note: When AutoCAD saves a drawing, it writes the drawing to a TMP file, deletes any current backup file (BAK), renames the DWG to BAK so that the BAK file is the newest version, and finally renames the TMP to DWG. In some instances, the last step fails (see AutoCAD file save process).
Possible detailed causes
Server environment; network attached storage (NAS) device; storage area network (SAN) device.
Distributed File System (DFS): A DFS allows system administrators to make it easier for users to access and manage files that are physically distributed across a network. With a DFS, files distributed across multiple servers can appear to users as if they reside in one place on the network.
Mirrored file servers: Multiple server systems present the same files and different locations.
Insufficient Windows profile permissions.
- Outdated or corrupted 3rd party software.
Network performance issues
Missing trusted file location and supported search path locations.
Synchronizing time between server and workstation.
Networks saturation/Excess server workload.
Defender Antivirus outbound rule missing.
Missing registry entry for network and cloud-enabling.
Virus protection on the client or server.
"Misbehaving" network drivers on the client or on the server.
Offline File syncing issues between the client system and the server.
Cloud storage solutions (DropBox, Google Drive, OneDrive, etc.) synchronize the folder where the drawings are stored on the local machine.
Solution:
There are several troubleshooting suggestions, but a few quick work-arounds can be:
Use SAVE AS to save the file under a new name and then, within the operating system, rename/replace the original drawing.
Attempt saving a second time after waiting a few seconds or attempt SAVE AS and overwrite the original drawing.
Reset the user-specific settings and restart using a default user profile.
Define the default location for BAK files to a local path. Use the MOVEBAK command for this.
Alternatively, type ISAVEBAK on the command line in AutoCAD and set it to 0 (zero). This turns off saving a backup file.
Type ISAVEPERCENT on the command line in AutoCAD and set it to 0 (zero). This stops appended saves, making sure that the full file is saved each time.
Type DEMANDLOAD on the command line in AutoCAD and set it to 0 (zero). This turns off the loading of registered apps for custom objects.
For further troubleshooting, do one or more of the following:
Install the latest updates for AutoCAD (see Install Updates, Add-ons, and Enhancements).
Install the latest update for Desktop Connector.
Upgrade to a newer version of AutoCAD (or install the latest version in trial mode to test).
Uninstall Autodesk Account Desktop (formerly named Autodesk Account). This software has been retired.
Prevent the computer from going to sleep.
Delete all temporary files (see How to delete temporary files in Windows).
Reboot the network server.
Disable Offline Files
Search for Control Panel > Sync Center > Manage offline files.
Click Disable offline files and then click OK.
Turn off file indexing on the folder where DWG files are stored
Right-click the folder > Properties > General > Advanced.
Turn off Allow files in the folder to have contents indexed in addition to file properties.
Click OK.
Disable antivirus software
- If this eliminates the problem, exceptions for AutoCAD and/or DWG, BAK, TMP files may need to be added or other antivirus settings examined (see How to set up antivirus (AV) exclusions to improve stability and performance of Autodesk software).
Check Windows Defender Firewall
If the computer connects to the internet through a firewall or a proxy server, ensure that the proxy is configured to allow unrestricted and anonymous access to the below domains. The default port numbers used are 80 for HTTP and 443 for HTTPS (see: Which URLs/Protocols need to be allowed for Autodesk subscription Licensing) or (see: "Establish an internet connection to continue" when launching Autodesk software in a proxy-secured environment). Add us to the inbound outbound rule
Missing Registry entry for linked cloud and network connections:
Check if mapped drives are available.
Press WINDOWS+R on the keyboard to bring up the Run window, enter REGEDIT, and click OK.
Navigate to: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System.
Right-click System and choose New > DWORD value.
Type EnableLinkedConnections and press Enter.
Double-click (or right-click > Modify) on EnableLinkedConnections.
In the Value data field, type 1 and then click OK.
Close the Registry Editor and restart the computer.
Add working path locations
In AutoCAD or Civil 3D, on the command line, type OPTIONS and hit 'Enter'.
In the 'Files' tab select the '+' for 'Supported File Search Path' and 'Trusted File Locations' and click 'Add' then 'Browse'.
Add in the location of the server, network, or cloud working folder file path for example, 'x:\servername....'.
Then click 'Apply' and then 'OK' to close.
Files permissions
Check that correct permissions are set on DWG and BAK files, and hidden DWL and DWL2 files.
Confirm that full read-write-modify permissions are on the folder location being saved to.
Files stored on inaccessible locations
- Opening a DWG file directly from an email or a CD/DVD disc does not allow saving back to that source.
Mapped drives
- Check that mapped drives are not timing out (see Mapped Drive Connection to Network Share May Be Lost (Microsoft)).
DFS (Distributed File System)
- Bypass DFS shares by creating a mapped network drive directly to the UNC path of the folder where the drawing files are stored.
Check latency or lag time between AutoCAD and the server. Workstations may not be getting cues from the server about file locks at the right time.
Test saving and resaving to the local drive and then to a share on another workstation to pinpoint the problem network location.
Check the network adapter settings on all Ethernet ports and make sure they are not on auto-negotiation. If possible, they should be set to the speed of the network at full duplex (see "Configuring Windows 10 for Wired Publicly Accessible Network Ports" by PittNet Wired).
There could also be a conflict or bad synchronization time between the server and the workstation. Server time stamp settings should be checked to confirm proper functionality.
Test user accounts
- Sign in to another system and test saving in AutoCAD and have someone else sign in to the same computer and test AutoCAD.
Corrupt user profile
Rebuild the user profile for Windows.
Test using an out-of-the-box profile (See How to reset Civil 3D to default, How to reset AutoCAD to defaults).
Cloud storage applications/drives
Disable any storage applications and drives or wait until the folder/drive is synchronized with the cloud and then try opening/saving again.
Set the cloud provider's settings to always keep a local copy of the files on the workstation (disable files-on-demand, choose 'offline' setting, etc.).
If the cloud provider has an option to prompt the user for backup synchronization, disable that option.
VPN
- Work with local data to pinpoint if the issue is related to the connection.