Issue:
Users reported that when trying to open a specific drawing or template in AutoCAD products, the program freezes or crashes.
Causes:
The following are causes of this issue:
Installation.
- AutoCAD product is not up to date.
- Software corruption.
- User profile corruption.
- Not all the minimum system requirements are met.
- Hardware.
- The graphics driver is out of date.
- The wrong graphics card is being used.
- Corrupt USB Flash drive.
- OS.
- Lack of system resources.
- Restrictive environment.
- Malware on the system.
- Windows updates are missing or failed, blocking installation of required components.
- The DWG file type is associated with acad.exe instead of aclauncher.exe.
- Network.
- Network drive issue.
- Inaccessible network share.
- Replacement of server/NAS.
- External internet Service Provider (ISP).
- VPN slowness.
- Large xref file, saved on a network drive.
- Cloud.
- Incompatible file storage solution.
- Cloud storage provider maintains all files online, but not on the local hard drive.
- Bad internet connection.
- Drawing.
- File corruption.
- File incompatibility.
- File size.
- Drawing version.
- Reference files lookup.
- Circular references.
- Corrupt or missing SHX shape files.
- PAGESETUP is configured to display the applied plot style table.
- DXE data extraction files placed on an unreachable network location are referenced in the DWG file.
- AEC objects.
- Third-party application/add-on.
Solution:
Try first this troubleshooting guide:
Troubleshooting Guide "Freeze or crash when opening drawings in AutoCAD products"
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Alternatively work through the following list, testing the drawing or the file open process after each. Some instructions apply only if a drawing can be opened at some point.
Installation
- Check the system against the minimum requirements of the program. Install all necessary operating system updates.
- Install the latest updates for AutoCAD. See Install Updates, Add-ons, and Enhancements.
- Delete the content of the %TEMP% folder. See How to delete temporary files in Windows.
- Reset AutoCAD to defaults See How to reset AutoCAD to defaults or How to reset Civil 3D to defaults.
- If using an AutoCAD toolset (a.k.a. "vertical") product, such as AutoCAD Architecture or Civil 3D, start the program with the vanilla AutoCAD profile and then open the drawing, or use a separate installation of plain AutoCAD to do so.
- Change profiles within AutoCAD. See Profiles Tab (Options Dialog Box).
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Go into Options and click the Profiles tab.
- Select a different profile, click Set Current, and then click OK.
Note: A new profile can be created when only one of them is available. If the drawing in question opens successfully under a different profile, the previous profile is damaged and should be discarded or imported again if a backup is available.
- Version 2021 and older, Repair the AutoCAD product. See How to repair or reinstall AutoCAD installation.
- Uninstall AutoCAD, redownload the installation package, and reinstall the program. See Clean uninstall of AutoCAD or verticals.
- Check the Windows Event Viewer for Errors. If Event Viewer shows Faulty module: libeay32_Ad_1.dll in location C:\Program Files\Autodesk\AutoCAD 20xx, rename the affected module to libeay32_Ad_1.dll.bak.
- If getting an "AclvServerHost.exe" error, do the following troubleshooting solution to attempt to fix the issue:
- Close AutoCAD.
- In Windows Task Manager go to the 'Services' tab or select the Windows button and type "services.msc".
- End the service called AcIvServerHost.exe.
- In File Explorer navigate to: C:\Program Files\Autodesk\AutoCAD 20xx\Inventor Server\Bin.
- Locate AclvServerHost.exe and rename the file to AclvServerHost.exe.bad.
- Note: Be sure that Windows is configured to show all file extensions.
- Copy the AclvServerHost.exe from a working installation of AutoCAD.
- Note: If no other stations are present, reset AutoCAD to defaults or do a clean uninstall of AutoCAD, making sure that the faulty AclvServerHost.exe and its corresponding folder of C:\Program Files\Autodesk\AutoCAD 20xx\Inventor Server\Bin is also uninstalled and no longer present.
- If there are missing SHX shapefiles, try to obtain these files and repair them, then use them to open the drawing.
Hardware
- Update the graphics driver. Be sure to update all graphics drivers for discrete and integrated cards. See How to update to the latest certified video driver.
- Check if the software is using a high-end graphics card. See How to configure Autodesk software to use high-performance graphics.
- Disable graphical hardware acceleration within the software. See How to enable or disable hardware acceleration in AutoCAD.
- Use a previous verison of DirectX: How to use a previous DirectX version in AutoCAD Products
OS
- If using AutoCAD for Mac on macOS 10.14 or 10.15, open System Preferences > Security & Privacy. Add AutoCAD to "Full Disk Access" and then under "Files and Folders" make sure that "Documents" is checked under AutoCAD.
- Create a Windows user profile as the current profile may be corrupt. See How to create a new local administrator Windows user account.
- Check the operating system for malware and remove it as appropriate. If suspecting software corruption, perform a clean uninstall of the current AutoCAD version along with Visual C++. For Windows 7, repair .Net Framework.
- Ensure that DWG-files are associated with aclauncher.exe. See DWG file type associativity in Windows.
Network
- Disconnect mapped drives from the system that are offline or nonfunctional.
- Make sure none of the folders in the file path are set to read-only.
- Test opening the file directly on the computer's local hard drive as opposed to opening it from a network location or through 3rd party file management/PLM solution. If the file opens locally, see the following articles:
- Support for Non-Microsoft Networks.
- Autodesk support for Network Attached Storage (NAS) and Storage Area Network (SAN) devices.
- Work from copies of the drawing files on a local hard drive instead of from a USB flash drive or third-party cloud services. See Autodesk Support for Non-Microsoft Networks.
- If a specific XREF, saved on a network drive, is too large and cannot be loaded, follow this solution:
- Disconnect from the network.
- Open the drawing and note the path of the referenced file.
- Close the drawing.
- Go to the path of the referenced file.
- Move the referenced file to a different location.
- Open the drawing. Now the reference will show as "Not found".
- Detach the reference and/or replace it as needed.
Cloud
- Copy the drawing into a different cloud folder. Try to open the drawing afterward.
- Download the drawing and open it from a local folder.
- Set system variable AUTOPLACEMENT to 0.
- Set system variable ACTIVITYINSIGHTSSUPPORT to 0.
Drawing
- Use the RECOVER command to open the file.
- Clean and repair the file See How to repair corrupt AutoCAD files.
- If the file is large, take steps to reduce the size of the file. See How to reduce the size of a DWG file in AutoCAD.
- Use the "Regapp ID Cleanup Utility" or the "Scale List Cleanup Utility" to clean the drawing. See Autodesk Downloads.
- Use a different version of AutoCAD to open the drawing. If it can be opened, test opening the file in the desired version of AutoCAD.
- Delete hatch patterns and save the file as a new name.
- Convert AEC objects using the AECTOAUTOCAD command.
- Open the file on a working system and save it under another/newer DXF/DWG-version format, such as version 2010 instead of 2007.
- Instead of opening the file, try using the INSERT command to insert it into an existing or newly created drawing.
- If the issue happens when opening the file after being able to save it, try deleting all proxy entities.
- Use the -EXPORTTOAUTOCAD command (or AECTOACAD) to resave the file.
- Run the PAGE SETUP command check the various tabs (Model and layouts), and deselect the option for "Display plot styles". If it is checked and if the Plot Style Table field is not set to 'None'.
- If the drawing contains referenced DWG files, images, or DXE-data extraction parameter files (Xrefs).
- Reattach, reload, or detach any Unreferenced or Not Found external reference files.
- Copy the file to a location so that the attachments will not be found. Examine each Xref file individually for circular references and remove all duplicate references that are found.
- If the drawing can be opened on a different system, look for and remove references, using an absolute path saved to an inaccessible network share.
- If the drawing cannot be opened at all, use the DWG Convert tool to create a copy of the drawing file which only contains valid external references.
- If the drawing opens intermittently, convert the attachments to overlays to avoid circular reference errors.
- Try to open any referenced images to confirm that they can be opened. If they cannot be opened, they might have become corrupt and need to be deleted. AutoCAD will hang indefinitely trying to open a corrupt image.
- If the referenced file is a DXE then copy it along with the main DWG file to the local computer. Adjust its'"saved path" in the main file by adding the new local path. (through the External References Tool palette)
- If references files are referencing each other in an endless loop, create a new drawing, insert the main drawing, containing the references, by using Design Center.
Third-party application/add-on
- If add-ons/plug-ins are installed, do any of the following:
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Start AutoCAD without any plug-ins and then test opening the drawing. See How to start an AutoCAD Product without any plug-ins or add-ons.
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Uninstall them and then test opening the drawing.
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- Use the -EXPORTTOAUTOCAD to remove/convert proxy objects.
- Run -PURGE with option R to remove registered apps.
See Also:
- AutoCAD crashes when multiple drawings are open
- Drawings take a long time to open in AutoCAD
- Error about AEC objects when opening a drawing in AutoCAD
- Understanding backup and autosave files in AutoCAD
- Unable to open/save drawings in AutoCAD over a VPN connection
- Unable to remove or delete a data link in AutoCAD
