Issue:
Users reported that the response time of AutoCAD is sluggish, showing one, or more of the following symptoms:
- Commands run slowly or hang after executed.
- Object selection lag.
- Mouse movements are slow, hang, skip, or hesitate.
- The program intermittently pauses or freezes.
- Drawing files are slow to open.
- Files and object display take a long time to regenerate during drawing navigation.
- Turning on hardware acceleration degrades performance.
- Degraded performance over time.
- Dialogs (like plot dialog) are getting opened slowly.
Causes:
Slow performance is often caused by file, hardware, or system issues:
File issues
-
A file is corrupted.
-
Huge file size.
- A file has unresolved external references.
- A file has saved numerous unneeded named objects, including blocks and registered apps.
- The components are placed with high coordinates (thumb rule: > 100.000).
- MTEXT placed in a block contains many different text formats.
- Many dynamic blocks contain wipeouts
- Dynamic input is enabled
Hardware and operating system issues
- Computer specifications do not meet the criteria outlined in the System Requirements for the version of AutoCAD in use. This includes amount of RAM, type of graphics card (GPU), and the central processing unit (CPU) in the machine.
- A graphics card is not certified or is malfunctioning.
- The graphics card driver is outdated.
- Graphics settings may not be compatible with a remote system.
- Dual graphics systems not using higher end graphics card.
- Too less refresh rate of 4K monitor.
- Monitors chained together with USB connection.
- Overheating.
- Nonspecific issues caused by docking stations (when using laptop computers)
- 100% disk usage in Task Manager
- The C:\ drive in Windows has less than 10% space free, which cause Windows becoming slow in general
- WMI (Windows Management Instrumentation) software corrupt or damaged.
- Power Options are set to "Power Saver".
Network issue
- Disconnected or slow network
- Unresolved network drive
- File is stored in an unsupported working location or in a folder that is syncing to one.
- Slow internet connection, when working from remote.
- Slow network connection.
- Drawing tries to connect to a network file, for example external references, drawing standards, ..., which cannot be opened or found.
Solution:
Try first this troubleshooting guide:
Troubleshooting Guide "Slow or poor performance in AutoCAD".
Alternatively follow these solutions:
Begin with the General Troubleshooting section. If more troubleshooting is necessary review the scenarios:
- If the problem only occurs with specific drawing files, begin with File Troubleshooting. If necessary follow-up with the Hardware and System solutions
- If the issue occurs with any drawing file:
- Are the files on the local machine - begin with the Hardware and System solutions
- Are the files on a network server - begin with the Network solutions
- If the network has been eliminated as a cause - go to the Hardware and System solutions
Try the solutions in the categories in order, testing AutoCAD each time. If one solution does not improve performance, proceed to the next strategy:
General troubleshooting
Verify the System Requirements and that AutoCAD Updates are installed.
- Does the computer meet the System Requirements for AutoCAD?
- Have all available updates* for AutoCAD been installed? Updates can be installed from the Autodesk Account or by checking Autodesk Access.
File Troubleshooting
- Performance issues related to drawing corruption or file bloat
To repair a drawing file and remove unreferenced objects.
- Open the drawing file.
- Audit and fix any errors:
- Type AUDIT on the command line.
- Type "Y" for Yes to fix any errors, then Enter.
- Remove unused named objects from the drawing:
- Type -PURGE on the command line.
- Type "A", press ENTER
- Type "*" (asterisk), press ENTER (the asterisk equates to All).
- Type "N" for No, press ENTER
- Purge Registered Applications (from the command line):
- Type -PURGE.
- "R" for Regapps (registered applications), press ENTER.
- Type "*", press ENTER (the asterisk equates to All).
- "N" when asked to verify each name to be purged, then Enter.
- Remove duplicate components
- Type OVERKILL.
- Select the whole geometry and right-click with your mouse afterward.
- In the dialog click OK.
- Save the drawing.
- Performance issues with drawings containing complex geometry such as 3D solids, nonmesh surfaces, and regions.
- Type CACHEMAXFILES at the Command prompt.
- Set it to 0 (zero)
- Restart AutoCAD.
- Set CACHEMAXFILES back to 256 after AutoCAD restarts.
- Visual Styles can impact performance.
- Turn off silhouette edges using the DISPSILH (System Variable).
- Test different visual styles, particularly 2D Wireframe vs. 3D Wireframe.
- For 3D select visual style "Shaded with Edges" or "Shaded". Both visual styles are using the newest graphic engine, increasing the performance for 3D significantly.
- MTEXT placed in a block contains many different text formats.
- Adjust the differing text formats to the current used Text style.
- Exclude the MTEXT from the block and place it outside the block.
- EXPLODE the affected block.
Performance issues when using the Blocks Palette (in AutoCAD 2020 or later) may be related to the 'Recent' blocks tab. Setting the BLOCKMRULIST (System Variable) which controls the number of most recently used blocks displayed in the Recent tab of the Blocks palette to 0 (zero) may improve performance.
- Type BLOCKMRULIST at the Command prompt
- Set the value to 0
- Many dynamic blocks contain wipeouts
- Place the blocks with WIPEOUT in a layer and freeze them out of the drawing.
- See Poor performance on specific AutoCAD drawings for extra solutions where:
- Huge file size.
- A file has unresolved external references.
- The components are placed with high coordinates (thumb rule: > 100.000)
- Dynamic Input is enabled.
- Set DYNMODE system variable to 0.
Operating System and Software
-
- Delete temporary files. See How to delete temporary files in Windows.
- Disable offline files. See Disable Offline Files on individual redirected folders.
- Disable or uninstall antivirus software. If this improves performance, add exceptions to the antivirus program. See How to set up antivirus (AV) exclusions to improve stability and performance of Autodesk software.
- Remove any add-ons, plug-ins, or 3rd party software installed into AutoCAD. If AutoCAD performs as expected, restore the components one at a time, testing AutoCAD with each component until the problematic component is found.
- Reset AutoCAD to default options. See How to reset AutoCAD to defaults or How to resolve user specific issues by resetting Civil 3D to defaults.
- Perform a clean reinstall of the software. See Clean uninstall of AutoCAD or verticals.
- Make sure that the C:\ drive has more than 10% of free disk space available.
- Check with your IT about repairing the Windows Management Instrumentation.
- Change power options to "High Performance".
- Open Control Panel and click "Power Options".
- Click "Create a Power Plan".
- Select option "High Performance".
- Click "Next" and afterward "Create".
Graphics and Peripherals
-
- In AutoCAD, use the GRAPHICSCONFIG (Command) which sets hardware acceleration on or off and provides access to display performance options to:
- Turn off "High Quality Geometry" or "Smooth Line Display."
- Turn off hardware acceleration. Some systems may work better with this setting turned off.
- Update the graphics card driver. See How to update to the latest certified video driver.
- Note: The card manufacturer may have a newer version of the driver available. It's recommended updating to the latest version of the driver. If the issue persists, then test with the driver listed on the certified hardware site.
- If using a dual graphics system, such as Intel integrated graphics along with an AMD or NVIDIA card, set AutoCAD to use the high-performance card. See How to configure Autodesk software to use high performance graphics.
- For systems with only the integrated graphics card, configure that card for high performance as indicated in the linked article.
- If using a laptop computer with an external monitor:
- Try making the external screen the main monitor:
- Right-click the desktop and choose "Display settings."
- Select the external screen.
- Scroll down to "Multiple displays" and select "Make this my main display."
- Restart the computer.
- Switch to only using the laptop screen.
- If slowdowns occur only when the external monitor is attached, check the connecting cables and docking station. Some graphics cards do not support multiscreen setups.
- Try removing extra monitors if using USB connections.
- Try making the external screen the main monitor:
- If connecting to a remote system, confirm that a monitor is connected to the receiving system. Be sure that the remote graphic settings do not conflict with the local settings.
- If laptops are used with docking stations, try disconnecting completely from the docking station and then test the performance of AutoCAD again.
- If disk usage in Task Manager is at 100%, see 10 Ways to Resolve a 100% Disk Usage on Windows 10.
- Increase refresh rate of monitor
- Right-click Windows Desktop and choose from context menu "Display Settings".
- Scroll down and click "Advanced Settings".
- In section "Choose a refresh rate" select a higher refresh rate if possible.
- In AutoCAD, use the GRAPHICSCONFIG (Command) which sets hardware acceleration on or off and provides access to display performance options to:
Network troubleshooting
A best practice for troubleshooting performance issues when working in a networked environment is to determine whether the root cause of the problem is with the network, the file Server, or the local machine.
- Move or copy the file and all associated files (xrefs, plot file, block references), from the file Server to the local drive. Alternatively turn off cloud-drive-sync for folders already on the local drive. If performance is as expected, then the cause of the problem is with the network or with the Server.
- If Tool Palettes are saved on a network drive, copy them to a local drive and update the path in the options, tab "Files", node "Tool Palettes File Locations".
- Check network stability and performance of the network.
- Start - Run - CMD - Enter
- Enter PING <servername or IP-address>
- Look for the reply time
- Thumb rule:
- Reply <50 ms: Good
- Reply between 50 ms - 100 ms: Somehow OK.
- Reply > 100 ms: Bad: Ask your network administrator for help
- Thumb rule:
- Check the percentage of the packets lost
- > 0%: Check with your network administrator.
- If possible, connect to the network using an Ethernet cord instead of using a wireless connection.
- Disconnect unresolved network drives.
- Select the network drive in Windows Explorer and choose from context menu "Disconnect drive".
- Look for unresolved drawings, which cannot be accessed to.
- Open the options and switch to tab "Files".
- Look in all nodes for network paths and check if these network paths are valid and that the user has enough permission to access them
- Open XREF-dialog and check for unresolved external references to validate the file exists at the saved path and the user has enough permission to use it.
- See Lag or poor performance when working on networked files in AutoCAD products for more solutions.
See Also:
- Autodesk Certified Hardware
- How to use a previous DirectX version in AutoCAD Products
- Cursor is slow, jumpy, twitchy, or jerky in AutoCAD
- Slow performance when switching between layouts in AutoCAD
- Optimizing AutoCAD performance within Windows environments
- Pan and zoom are slow through viewports in AutoCAD
- Autodesk support for Network Attached Storage (NAS) and Storage Area Network (SAN) devices
- Selecting polylines with huge numbers of vertices freezes AutoCAD
- How to improve performance in drawings containing hatches in AutoCAD Products
- Slow performance when using xrefs in AutoCAD
- Hardware acceleration cannot be enabled in AutoCAD products
- Delay when running commands in AutoCAD products
