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"PDF failed to generate" in AutoCAD Web App

Technical Support

Issue:

Users reported, that when clicking the Plot to PDF button in AutoCAD Web App, the PDF process starts but then fails with the following message:

PDF failed to generate

[File name].pdf failed to generate.


PDF failed to generate message in AutoCAD Web App  
 
 

Causes:

  • Browser problem.
  • Txt.shx font used in drawings.
  • Security settings preventing access to URL needed for PDF generation
  • Timeout limit reached for PDF generation in AutoCAD Web App.

Solution:

Clear Browser Issue

To resolve the issue, try one or more of the following steps:
  1. Clear browser history, cache and cookies, restart browser and sign in again.
  2. Try using different browsers
  3. Check browser update
  4. Try using AutoCAD Web in the Incognito tab of any browser.
  5. Type the PLOT command on the command line and select the plot style, paper size and orientation required to plot the PDF.

Txt.shx font used in drawings

Edit the drawings' text styles to use a font other than txt.shx. For individual text objects which do not align with the text styles, they'll need to be edited one at a time.

Security settings

Create an exception for the following URLs in the security settings of the network:

  • https://storage.autocad360.com/storage/v1/stagefiles/plot
  • wss://websockets.forgedesignautomation.io
    

Enable the IP addresses, URLs, URIs and domains from this article:

Timeout reached

The AutoCAD Web App has a 900-second limit on how long it will work on generating a PDF. If it has not finished by that point, an error will appear and no PDF will be generated. If reducing the amount of pages or drawing complexity is not an option, then using the desktop version of AutoCAD or DWG TrueView is recommended for publishing the drawing (set) to PDF.

Products:

AutoCAD for Mac; AutoCAD web app;

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