Issue:
Users reported that an error message like one of the following is displayed when waking up a computer from Sleep mode, while working in the product, or when launching Autodesk products versions 2020 or newer:
License Error
The License manager is not functioning or is improperly installed.
AutoCAD LT will shut down now.
AutoCAD LT will shut down now.
ADLSDK_UPDATE_REASON_REGISTRATION_ERROR
6:failed to find sdk connection
6:failed to find sdk connection
License Error
The License manager is not functioning or is improperly installed. AutoCAD will shut down now.
ADLSDK_UPDATE_REASON_REGISTRATION_ERROR
6:failed to find corresponding agent
6:failed to find corresponding agent
License Error
The License manager is not functioning or is improperly installed. AutoCAD will shut down now.
ADLSDK_UPDATE_REASON_REGISTRATION_ERROR
1:processReconnect failed: [SERVICE] 6: failed to find corresponding agent
Causes:
- Potential conflict with the 11.1 Update for the Autodesk Desktop Licensing Service (ADLS) and the Sleep Mode.
- The Services used for ADLS are timing out.
- Third party security software interfering with the ADLS.
Solution:
To solve the issue, try the following:
Install the latest Autodesk Licensing Service update
- Go to the folder: C:\Program Files (x86)\Common Files\Autodesk Shared\AdskLicensing
- Right-click uninstall.exe and select "Run as administrator".
- Wait until the folder becomes empty.
- Close all Autodesk products.
- Download and unzip the latest version of the Autodesk Desktop Licensing Service.
- Double-click the EXE file to start the installation.
Increase Sleep mode time
- Open up the search by hitting the Windows Key + Q shortcut.
- Type "sleep" and select "Choose when the PC sleeps".
- You should see two options:
- Screen: Configure when the screen goes to sleep.
- Sleep: Configure when the PC will hibernate.
- Increase the time (or use “Never”) for Sleep using the drop-down menus.
Change Services to Automatic (Delayed Start)
Verify that the Autodesk Desktop Licensing Service and FlextNet Licensing Service are running from the Windows Services console.
Change the service startup type to Automatic (Delayed Start) for both services.
Uninstall and reinstall the Autodesk Identity Manager
- Go to Control Panel and open Programs and Features.
- Look for the "Autodesk Identity Manager" component and uninstall it.
- Reboot the system.
- Download and install the component from here.
Check for conflicting third-party software
Make sure you are not using any conflicting applications.
See: Autodesk Licensing Service: Known Conflicting Applications