Description
What's New in the Managed .NET API for AutoCAD 2025.
New in Autodesk.AutoCAD.DatabaseServices
Topic |
Description |
---|---|
Looks up a runtime ID in a map and returns the associated Database object. | |
Looks up a database in a map and returns its runtime ID. | |
Get this database instance's runtime ID. | |
Sets the UprightAt bit for the shape (or text string) at position index in the LinetypeTableRecord. If isUprightAt is True, then the bit is set and the shape will orient itself relative to the line it's embedded within. If isUprightAt is False, then the shape will orient itself relative to the current UCS if isUcsOriented is True.index must be greater than or equal to zero, but less than the value returned from NumDashes. index is a zero-based index (shapes and text strings have the same index as the dash that precedes them in the linetype definition) with the first dash in the linetype being index 0.For more information on linetype definitions and embedded shapes, see the "Linetypes" section of the AutoCAD Customization Guide. | |
Gets the value of the UprightAt bit for the shape (or text string) set at position index in the LinetypeTableRecord. | |
Returns an equivalent string representation of this object, in the culture-specific format defined by provider, displayed with a specific format. |
New in Autodesk.AutoCAD.DataExtraction
Topic |
Description |
---|---|
Gets data for this object from a JsonNode object. | |
Creates a new JsonNode object based on this object. | |
Gets data for this object from a JsonNode object. | |
Accesses a list of handles that represent the selected objects for which the data will be extracted. | |
Creates a new JsonNode object based on this object. | |
Method is used to load and return the extraction settings from a BLK file. | |
Method is used to load and return the extraction settings from a DXEX file. | |
Gets data for this object from a JsonNode object. | |
Creates a new JsonNode object based on this object. | |
Gets data for this object from a JsonNode object. | |
Creates a new JsonNode object based on this object. | |
Gets data for this object from a JsonNode object. | |
Creates a new JsonNode object based on this object. | |
Gets data for this object from a JsonNode object. | |
Creates a new JsonNode object based on this object. |
New in Autodesk.AutoCAD.Geometry
Topic |
Description |
---|---|
Returns an equivalent string representation of this object, in the culture-specific format defined by provider, displayed with a specific format. | |
Returns an equivalent string representation of this object, in the culture-specific format defined by provider, displayed with a specific format. |
New in Autodesk.AutoCAD.GraphicsInterface
Topic |
Description |
---|---|
Returns True if the current implementation of the Graphics Interface supports Curve Trait. | |
Method draws a 3D curve object. |
New in Autodesk.AutoCAD.Runtime
Topic |
Description |
---|---|
Listens to the background thread for assemblies to be loaded, and then when it is safe, the assemblies are loaded. | |
Initializes the .NET Runtime using ICLRRuntimeHost. |
New in Autodesk.AutoCAD.ApplicationServices.Core
Topic |
Description |
---|---|
Checks whether ADP instrumentation is disabled. |
New in Autodesk.Windows.Palettes
Topic |
Description |
---|---|
Get and set the PaletteTabScrollHoverColor value. |
New in Autodesk.Windows.Forms
Topic |
Description |
---|---|
Gets the current scale factor of the container that contains the control. |