PolygonMesh Object (ActiveX)

A free-form 3D mesh.

Supported Platforms: Windows only

Class Information

Class Name

AcadPolygonMesh

Object Inheritance
Object
   AcadObject
      AcadEntity
         AcadPolygonMesh
Create Using

VBA

ModelSpace.AddPolygonMesh
PaperSpace.AddPolygonMesh
Block.AddPolygonMesh
Access Via

VBA

ModelSpace.Item
PaperSpace.Item
Block.Item
SelectionSet.Item
Group.Item

Members

These members are part of this object:

Remarks

A PolygonMesh object is an M x N mesh where M represents the number of vertices in a row of the mesh and N represents the number of vertices in a column of the mesh.

A mesh can be open or closed in either or both the M and N directions. A mesh that is closed in a given direction is considered to be continuous from the last row or column on to the first row or column.



To create a PolygonMesh use the Add3DMesh method.