Visual LISP で作業を開始する

アプリケーションがどのように動作するかを確認しましたが、それを Visual LISP で開発することができます。しかしその前に、Visual LISP が AutoCAD からコントロールが戻るまで待機しているときに何が起こるかを実験してみましょう。既に、体験された方もいらっしゃることでしょう。

Visual LISP が AutoCAD からコントロールが戻るまで待機する様子を観察するには

  1. [管理]タブ [アプリケーション]パネル [アプリケーション ロード]をクリックします。
  2. Tutorial¥VisualLISP フォルダから gardenpath.vlx を選択し、[ロード]をクリックします。
  3. [閉じる]をクリックします。
  4. AutoCAD のコマンド プロンプトに対して、vlisp と入力して Visual LISP を起動します。
  5. AutoCAD ウィンドウに切り替えて(タスクバーで AutoCAD をクリックするか、[Alt]+[Tab]を押して AutoCAD を選択し)、AutoCAD のコマンド プロンプトに対して、gpath と入力します。
  6. gpath からのプロンプトに応答する前に、Visual LISP ウィンドウに切り替えます。

    Visual LISP ウィンドウでは、マウス ポインタは Visual LISP のアイコンとして表示され、どのコマンドも選択できず、Visual LISP ウィンドウのどこにもテキストを入力できません。このポインタ アイコンは、Visual LISP で作業を再開する前に、AutoCAD での操作を完了させる必要があることを表しています。Visual LISP ポインタを目にしたら、このことを思い出してください。

  7. AutoCAD ウィンドウに戻り、gpath からのすべてのプロンプトに応答します。

これから、「庭園の歩道」アプリケーションを開発します。

Visual LISP でアプリケーションの開発を開始するには

  1. Visual LISP の[ファイル]メニューから、[ファイルを新規作成]をクリックします。
  2. テキスト エディタ ウィンドウ(「<Untitled-0>」と表示されたウィンドウ)に次のコードを入力します。コメントは、省略してもかまいません。
    ;;; Function C:GPath is the main program function and defines the 
    ;;; AutoCAD GPATH command.
    (defun C:GPath ()
      ;; Ask the user for input: first for path location and
      ;; direction, then for path parameters. Continue only if you have
      ;; valid input.
      (if (gp:getPointInput)      ; 
        (if (gp:getDialogInput)
          (progn
            ;; At this point, you have valid input from the user.
            ;; Draw the outline, storing the resulting polyline 
            ;; "pointer" in the variable called PolylineName.
            (setq PolylineName (gp:drawOutline))
            (princ "\nThe gp:drawOutline function returned <")
            (princ PolylineName)
            (princ ">")
            (Alert "Congratulations - your program is complete!")
          )
        (princ "\nFunction cancelled.")    
       )
       (princ "\nIncomplete information to draw a boundary.")
      )
      (princ)  ; exit quietly
    )
    ;;; Display a message to let the user know the command name.
    (princ "\nType gpath to draw a garden path.")
    (princ)
  3. メニューから[ファイル] [名前を付けて保存]を選択し、新しいファイルのコードを <AutoCAD フォルダ>¥Tutorial¥VisualLISP¥MyPath¥gpmain.lsp に保存します。
  4. 入力したコードを見直します。