vl-catch-all-error-p (AutoLISP)

Determines whether an argument is an error object returned from vl-catch-all-apply

Supported Platforms: Windows and Mac OS

Signature

(vl-catch-all-error-p arg)
arg

Type: Integer, Real, String, List, Subroutine, Ename (entity name), T, nil, or catch-all-apply-error

Any argument.

Return Values

Type: T or nil

T, if the supplied argument is an error object returned from vl-catch-all-apply; otherwise nil.

Examples

Divide by zero using vl-catch-all-apply:

(setq catchit (vl-catch-all-apply '/ '(50 0)))
#<%catch-all-apply-error%>

Use vl-catch-all-error-p to determine if the value returned by vl-catch-all-apply is an error object:

(vl-catch-all-error-p catchit)
T