vl-catch-all-error-message (AutoLISP)

Returns a string from an error object

Supported Platforms: Windows and Mac OS

Signature

(vl-catch-all-error-message error-obj)
error-obj

Type: catch-all-apply-error

An error object returned by vl-catch-all-apply.

Return Values

Type: String

A textual value containing an error message.

Examples

Divide by zero using vl-catch-all-apply:

(setq catchit (vl-catch-all-apply '/ '(50 0)))
#<%catch-all-apply-error%>

The vl-catch-all-apply function traps the error and returns an error object. Use vl-catch-all-error-message to see the error message contained in the error object:

(vl-catch-all-error-message catchit)
"divide by zero"