Error-Handling Functions Reference (AutoLISP)

The following table provides summary descriptions of the AutoLISP error-handling functions.

Error-handling functions

Function

Description

(alert string)

Displays an alert dialog box with the error or warning message passed as a string

(*error* string)

A user-definable error-handling function

(exit)

Forces the current application to quit

(*pop-error-mode*)

Error-handling function that ends the previous call to *push-error-using-command* or *push-error-using-stack*

(*push-error-using-command*)

Error-handling function that indicates the use of the command function within a custom *error* handler

(*push-error-using-stack*)

Error-handling function that indicates the use of variables from the AutoLISP stack within a custom *error* handler

(quit)

Forces the current application to quit

(vl-catch-all-apply 'function list)

Passes a list of arguments to a specified function and traps any exceptions

(vl-catch-all-error-message error-obj)

Returns a string from an error object

(vl-catch-all-error-p arg)

Determines whether an argument is an error object returned from vl-catch-all-apply