vlax-import-type-library (AutoLISP/ActiveX)

Imports information from a type library

Supported Platforms: Windows only

Signature

(vlax-import-type-library :tlb-filename filename [:methods-prefix mprefix  :properties-prefix pprefix :constants-prefix cprefix])
filename

Type: String

Name of the type library. A file can be one of the following types:

  • A type library (TLB) or object library (OLB) file
  • An executable (EXE) file
  • A library (DLL) file containing a type library resource
  • A compound document holding a type library
  • Any other file format that can be understood by the LoadTypeLib API

If you omit the path from tlb-filename, AutoCAD looks for the file in the support file search path.

mprefix

Type: String

Prefix to be used for method wrapper functions. For example, if the type library contains a Calculate method and the mprefix parameter is set to “cc-”, Visual LISP generates a wrapper function named cc-Calculate. This parameter defaults to “”.

pprefix

Type: String

Prefix to be used for property wrapper functions. For example, if the type library contains a Width property with both read and write permissions, and pprefix is set to “cc-”, then Visual LISP generates wrapper functions named cc-get-Width and cc-put-Width. This parameter defaults to “”.

cprefix

Type: String

Prefix to be used for constants contained in the type library. For example, if the type library contains a ccMaxCountOfRecords property with both read and write permissions, and cprefix is set to “cc-”, Visual LISP generates a constant named cc-ccMaxCountOfRecords. This parameter defaults to “”.

Note: Keywords are required when passing arguments to vlax-import-type-library.

Return Values

Type: T or nil

T, if successful; otherwise, nil if the library could not be imported.

Remarks

Function wrappers created by vlax-import-type-library are available only in the context of the document vlax-import-type-library was issued from.

In the current release, vlax-import-type-library is executed at runtime, rather than at compile time. In future releases, this may change. The following practices are recommended when using vlax-import-type-library:

Examples

Import a Microsoft Word type library, assigning the prefix “msw-” to methods and properties, and “mswc-” to constants:

(vlax-import-type-library
  :tlb-filename "c:/program files/microsoft office/office14/msword.olb"
  :methods-prefix "msw-"
  :properties-prefix "msw-"
  :constants-prefix "mswc-")
T