vlax-get-object (AutoLISP/ActiveX)

Returns a running instance of an application object

Supported Platforms: Windows only

Signature

(vlax-get-object prog-id)
prog-id

Type: String

Identifies the desired application object. The format of prog-id is:

appname.objecttype

where appname is the name of the application and objecttype is the application object. The objecttype may be followed by a version number.

Note: You can usually find the prog-id for an application in that application's Help.

Return Values

Type: VLA-object or nil

The application object; otherwise nil, if there is no instance of the specified object currently running.

Examples

Obtain the application object for the Excel program:

(vlax-get-object "Excel.Application")
#<VLA-OBJECT _Application 0017bb5c>