The following table provides summary descriptions of the AutoLISP functions for handling drawing objects.
Functions for handling drawing objects |
|
---|---|
Function |
Description |
(vlax-create-object "prog-id") |
Creates a new instance of an ActiveX object |
(vlax-dump-object obj) |
Lists an object's methods and properties |
(vlax-erased-p obj) |
Determines whether an object was erased |
(vlax-get-acad-object) |
Retrieves the top-level AutoCAD application object for the current AutoCAD session |
(vlax-get-object "prog-id") |
Returns a running instance of an ActiveX object |
(vlax-get-or-create-object "prog-id") |
Returns a running instance of an ActiveX object, if one exists, otherwise starts a new instance of the object |
(vlax-import-type-library :tlb-filename filename [ :methods-prefix mprefix :properties-prefix pprefix :constants-prefix cprefix]) |
Imports information from a type library |
(vlax-method-applicable-p obj method) |
Determines whether an object supports a particular method |
(vlax-object-released-p obj) |
Determines whether an object has been released |
(vlax-read-enabled-p obj) |
Determines whether an object can be read |
(vlax-release-object obj) |
Releases a drawing object |
(vlax-typeinfo-available-p obj) |
Determines whether type library information is present for the specified type of object |
(vlax-write-enabled-p obj) |
Determines whether an AutoCAD drawing object can be modified |