vlax-curve-getParamAtPoint (AutoLISP/ActiveX)

Returns the parameter of the curve at the point

Supported Platforms: Windows only

Signature

(vlax-curve-getParamAtPoint curve-obj point)
curve-obj

Type: VLA-object

The object to be measured.

point

Type: List

A 3D point (in WCS) on curve-obj.

Return Values

Type: Real or nil

A number representing a parameter, if successful; otherwise nil.

Examples

Assuming that ellipseObj points to the ellipse shown in the example for vlax-curve-getArea, set OSNAP to tangent and select the point where the line is tangent to the ellipse:

(setq selPt (getpoint))
(7.55765 5.55066 0.0)

Get the parameter value at the selected point:

(vlax-curve-getParamAtPoint ellipseObj selPt)
4.58296