vlax-curve-getDistAtPoint (AutoLISP/ActiveX)

Returns the length of the curve's segment between the curve's start point and the specified point

Supported Platforms: Windows only

Signature

(vlax-curve-getDistAtPoint curve-obj point)
curve-obj

Type: VLA-object

The object to be measured.

point

Type: List

A 3D point list (in WCS) on curve-obj.

Return Values

Type: Real or nil

A number if successful; otherwise nil.

Examples

Set OSNAP to tangent and select the point where the line is tangent to the curve:

(setq selPt (getpoint))
(4.91438 6.04738 0.0)

Determine the distance from the start of the curve to the selected point:

(vlax-curve-getDistAtPoint splineObj selpt)
5.17769