alert (AutoLISP)

Displays a dialog box containing an error or warning message

Supported Platforms: Windows and Mac OS

Signature

(alert msg)
msg

Type: String

The message to display in the alert box.

Return Values

Type: nil

Always returns nil.

Examples

Display a message in an alert box:

(alert "That function is not available.")

Display a multiple line message, by using the newline character in string:

(alert "That function\nis not available.")
Note: Line length and the number of lines in an alert box are platform, device, and window dependent. AutoCAD truncates any string that is too long to fit inside an alert box.