vl-remove (AutoLISP)

Removes elements from a list

Supported Platforms: Windows and Mac OS

Signature

(vl-remove element-to-remove lst)
element-to-remove

Type: Integer, Real, String, List, File, Ename (entity name), T, or nil

The value of the element to be removed; may be any LISP data type.

lst

Type: List

Any list.

Return Values

Type: List or nil

The lst with all elements except those equal to element-to-remove.

Examples

(vl-remove pi (list pi t 0 "abc"))
(T 0 "abc")