member (AutoLISP)

Searches a list for an occurrence of an expression and returns the remainder of the list, starting with the first occurrence of the expression

Supported Platforms: Windows and Mac OS

Signature

(member expr lst)
expr

Type: Integer, Real, String, List, Ename (entity name), T, or nil

The expression to be searched for.

lst

Type: List

The list in which to search for expr.

Return Values

Type: List or nil

A list; otherwise nil, if there is no occurrence of expr in lst.

Examples

(member 'c '(a b c d e))
(C D E)

(member 'q '(a b c d e))
nil