Returns the string representation of LISP data as if it were output by the princ function
Supported Platforms: Windows and Mac OS
(vl-princ-to-string data)
Type: Integer, Real, String, List, Ename (entity name), T, or nil
Any AutoLISP data.
Type: String
A string containing the printed representation of data as if displayed by princ.
(vl-princ-to-string "abc") "abc" (vl-princ-to-string "c:\\acadwin") "C:\\ACADWIN" (vl-princ-to-string 'my-var) "MY-VAR"
(vl-princ-to-string "abc") "abc" (vl-princ-to-string "/myutilities") "/myutilities" (vl-princ-to-string 'my-var) "MY-VAR"