Returns the string representation of LISP data as if it were output by the prin1 function
Supported Platforms: Windows and Mac OS
(vl-prin1-to-string data)
Type: Integer, Real, String, List, Ename (entity name), T, or nil
Any AutoLISP data.
Type: String
A textual value containing the printed representation of data as if displayed by prin1.
(vl-prin1-to-string "abc") "\"abc\"" (vl-prin1-to-string "c:\\acadwin") "\"C:\\\\ACADWIN\"" (vl-prin1-to-string 'my-var) "MY-VAR"
(vl-prin1-to-string "abc") "\"abc\"" (vl-prin1-to-string "/myutilities") "\"/myutilities\"" (vl-prin1-to-string 'my-var) "MY-VAR"