The following table provides summary descriptions of the AutoLISP string-handling functions.
String-handling functions |
|
---|---|
Function |
Description |
(read [string]) |
Returns the first list or atom obtained from a string |
(strcase string [which]) |
Returns a string where all alphabetic characters have been converted to uppercase or lowercase |
(strcat [string1 [string2 ...]) |
Returns a string that is the concatenation of multiple strings |
(strlen [string ...]) |
Returns an integer that is the number of characters in a string |
(substr string start [length]) |
Returns a substring of a string |
(vl-prin1-to-string object) |
Returns the string representation of any LISP object as if it were output by the prin1 function |
(vl-princ-to-string object) |
Returns the string representation of any LISP object as if it were output by the princ function |
(vl-string->list string) |
Converts a string into a list of character codes |
(vl-string-elt string position) |
Returns the ASCII representation of the character at a specified position in a string |
(vl-string-left-trim character-set string) |
Removes the specified characters from the beginning of a string |
(vl-string-mismatch str1 str2 [pos1 pos2 ignore-case-p]) |
Returns the length of the longest common prefix for two strings, starting at specified positions |
(vl-string-position char-code str [ start-pos [from-end-p]]) |
Looks for a character with the specified ASCII code in a string |
(vl-string-right-trim character-set string) |
Removes the specified characters from the end of a string |
(vl-string-search pattern string [ start-pos]) |
Searches for the specified pattern in a string |
(vl-string-subst new-str pattern string [start-pos]) |
Substitutes one string for another, within a string |
(vl-string-translate source-set dest-set str) |
Replaces characters in a string with a specified set of characters |
(vl-string-trim char-set str) |
Removes the specified characters from the beginning and end of a string |
(wcmatch string pattern) |
Performs a wild-card pattern match on a string |