vl-list-exported-functions (AutoLISP/Visual LISP IDE)

Lists exported functions

Supported Platforms: Windows only

Signature

(vl-list-exported-functions [appname])
appname

Type: String

Name of a loaded VLX application. Do not include the .vlx extension.

Return Values

Type: List

A list of strings naming exported functions; otherwise nil, if there are no functions exported from the specified VLX. If appname is omitted or is nil, vl-list-exported-functions returns a list of all exported functions (for example, c: functions) except those exported from VLX namespaces.

Examples

(vl-list-exported-functions "whichexpns")
("WHICHNAMESPACE")