vl-vlx-loaded-p (AutoLISP)

Determines whether a separate-namespace VLX is currently loaded

Supported Platforms: Windows only

Signature

(vl-vlx-loaded-p appname)
appname

Type: String

Name of a VLX application.

Return Values

Type: T or nil

T if the application is loaded, nil if it is not loaded.

Examples

Check to see if the vlxns application is loaded in its own namespace:

(vl-vlx-loaded-p "vlxns")
nil

The application is not loaded in its own namespace.

Now load vlxns:

(load "vlxns.vlx")
nil

Check to see if the vlxns application loaded successfully:

(vl-vlx-loaded-p "vlxns")
T

This example assumes vlxns was defined to run in its own namespace. If the application was not defined to run in its own namespace, it would load into the current document's namespace and vl-vlx-loaded-p would return nil.