vlr-remove-all (AutoLISP/ActiveX)

Disables all reactors of the specified type

Supported Platforms: Windows only

Signature

(vlr-remove-all [reactor-type])
reactor-type

Type: Symbol

One of the following:

  • :VLR-AcDb-Reactor

  • :VLR-Command-Reactor

  • :VLR-DeepClone-Reactor

  • :VLR-DocManager-Reactor

  • :VLR-DWG-Reactor

  • :VLR-DXF-Reactor

  • :VLR-Editor-Reactor

  • :VLR-Insert-Reactor

  • :VLR-Linker-Reactor

  • :VLR-Lisp-Reactor

  • :VLR-Miscellaneous-Reactor

  • :VLR-Mouse-Reactor

  • :VLR-Object-Reactor

  • :VLR-SysVar-Reactor

  • :VLR-Toolbar-Reactor

  • :VLR-Undo-Reactor

  • :VLR-Wblock-Reactor

  • :VLR-Window-Reactor

  • :VLR-XREF-Reactor

If no reactor-type is specified, vlr-remove-all disables all reactors.

Return Values

Type: List

A list of lists. The first element of each list identifies the type of reactor, and the remaining elements identify the disabled reactor objects. The function returns nil if there are no reactors active.

Examples

The following function call disables all editor reactors:

(vlr-remove-all :vlr-editor-reactor)
((:VLR-Editor-Reactor #<VLR-Editor-Reactor>))

The following call disables all reactors:

(vlr-remove-all)
((:VLR-Object-Reactor #<VLR-Object-Reactor> #<VLR-Object-Reactor>
#<VLR-Object-Reactor>)(:VLR-Editor-Reactor#<VLR-Editor-Reactor>))