Selection Set Manipulation Functions Reference (AutoLISP)

The following table provides summary descriptions of the AutoLISP selection set manipulation functions.

Selection set manipulation functions

Function

Description

(ssadd [ename [ss]])

Adds an object (entity) to a selection set, or creates a new selection set

(ssdel ename ss)

Deletes an object (entity) from a selection set

(ssget [mode] [pt1 [pt2]] [pt-list] [filter-list])

Prompts the user to select objects (entities), and returns a selection set

(ssgetfirst)

Determines which objects are selected and gripped

(sslength ss)

Returns an integer containing the number of objects (entities) in a selection set

(ssmemb ename ss)

Tests whether an object (entity) is a member of a selection set

(ssname ss index)

Returns the object (entity) name of the indexed element of a selection set

(ssnamex ss index)

Retrieves information about how a selection set was created

(sssetfirst gripset [pickset])

Sets which objects are selected and gripped