ssmemb (AutoLISP)

Tests whether an object (entity) is a member of a selection set

Supported Platforms: Windows and Mac OS

Signature

(ssmemb ename ss)
ename

Type: Ename (entity name)

An entity name.

ss

Type: Pickset (selection set)

A selection set.

Return Values

Type: Ename (entity name) or nil

If ename is a member of ss, ssmemb returns the entity name. If ename is not a member, ssmemb returns nil.

Examples

In the following examples, entity name e2 is a member of selection set ss, while entity name e1 is not a member of ss:

(ssmemb e2 ss)
<Entity name: 1d62d68>

(ssmemb e1 ss)
nil