print (AutoLISP)

Prints an expression to the command line, or writes an expression to an open file

Supported Platforms: Windows and Mac OS

Signature

(print [expr [file-desc]])
expr

Type: Integer, Real, String, List, Symbol, File, Subroutine, Ename (entity name), T, or nil

A string or AutoLISP expression. Only the specified expr is printed; no newline or space is included.

file-desc

Type: File or nil

A file descriptor for a file opened for writing.

Return Values

Type: Integer, Real, String, List, Symbol, File, Ename (entity name), T, or nil

The value of the evaluated expr. If called with no arguments, print returns a null symbol.

Remarks

This function is the same as prin1, except it prints a newline character before expr, and prints a space following expr.

Examples

N/A