Display Control Functions Reference (AutoLISP)

The following table provides summary descriptions of the AutoLISP display control functions.

Display control functions

Function

Description

(graphscr)

Displays the AutoCAD graphics screen

(grdraw from to color [highlight])

Draws a vector between two points, in the current viewport

(grtext [box text [highlight]])

Writes text to the status line or to screen menu areas

(grvecs vlist [trans])

Draws multiple vectors on the graphics screen

(menucmd string)

Issues menu commands, or sets and retrieves menu item status

(menugroup groupname)

Verifies that a menu group is loaded

(prin1 [expr [file-desc]])

Prints an expression to the command line or writes an expression to an open file

(princ [expr [file-desc]])

Prints an expression to the command line, or writes an expression to an open file

(print [expr [file-desc]])

Prints an expression to the command line, or writes an expression to an open file

(prompt msg)

Displays a string on your screen's prompt area

(redraw [ename [mode]])

Redraws the current viewport or a specified object (entity) in the current viewport

(terpri)

Prints a newline to the Command line

(textpage)

Switches from the graphics screen to the text screen

(textscr)

Switches from the graphics screen to the text screen (like the AutoCAD Flip Screen function key)

(vports)

Returns a list of viewport descriptors for the current viewport configuration