The following table provides summary descriptions of the AutoLISP conversion functions.
Conversion functions |
|
---|---|
Function |
Description |
(angtof string [mode]) |
Converts a string representing an angle into a real (floating-point) value in radians |
(angtos angle [mode [precision]]) |
Converts an angular value in radians into a string |
(ascii string) |
Returns the conversion of the first character of a string into its ASCII character code (an integer) |
(atof string) |
Returns the conversion of a string into a real |
(atoi string) |
Returns the conversion of a string into an integer |
(chr integer) |
Returns the conversion of an integer representing an ASCII character code into a single-character string |
(cvunit value from to) |
Converts a value from one unit of measurement to another |
(distof string [mode]) |
Converts a string that represents a real (floating-point) value into a real value |
(itoa int) |
Returns the conversion of an integer into a string |
(rtos number [mode [precision]]) |
Converts a number into a string |
(trans pt from to [disp]) |
Translates a point (or a displacement) from one coordinate system to another |