vlax-method-applicable-p (AutoLISP/ActiveX)

Determines if an object supports a particular method

Supported Platforms: Windows only

Signature

(vlax-method-applicable-p obj method)
obj

Type: VLA-object

An object.

method

Type: Symbol or String

A symbol or string containing the name of the method to be checked.

Return Values

Type: T or nil

T, if the object supports the method; otherwise nil.

Examples

The following commands are issued against a LightweightPolyline object:

(vlax-method-applicable-p WhatsMyLine 'copy)
T

(vlax-method-applicable-p WhatsMyLine 'AddBox)
nil