vl-doc-import (AutoLISP)

Imports a previously exported function into a VLX namespace

Supported Platforms: Windows only

Signature

(vl-doc-import application ['function ...])
application

Type: String

Name of the VLX application whose functions are to be imported. Do not include the .vlx extension in the name.

function

Type: Subroutine

One or more symbols naming functions to be imported. If no functions are specified, all functions exported by application will be imported.

Return Values

Type: nil or error

nil if successful; otherwise an error occurs

Remarks

This function can be used in a separate-namespace VLX to import a function that was previously exported from another VLX loaded from the same document.

The vl-doc-import function should be used only at the top level in a file, and never inside other forms (for example, not within a defun).

Examples

Import function ldataget from the ldatatest application:

(vl-doc-import "ldatatest" 'ldataget)
nil