vl-doc-export (AutoLISP)

Makes a function available to the current document

Supported Platforms: Windows only

Signature

(vl-doc-export 'function)
'function

Type: Subroutine

A symbol naming the function to be exported.

Return Values

Type: T

Always returns T.

Remarks

When issued from a VLX that runs in its own namespace, vl-doc-export exposes the specified function to any document namespace that loads the VLX.

The vl-doc-export function should be used only at the top level in a file, and never inside other forms (for example, not within a defun).

Examples

The following code shows the contents of a file named kertrats.lsp. This file is compiled into a VLX that runs in its own namespace. The VLX file is named kertrats.vlx. The vl-doc-export call makes the kertrats function visible to any document that loads kertrats.vlx:

(vl-doc-export 'kertrats)
(defun kertrats ()
  (princ "This function goes nowhere") 
)