done_dialog (AutoLISP/DCL)

Terminates a dialog box

Supported Platforms: Windows only

Signature

(done_dialog [status])
status

Type: Integer

A positive integer that start_dialog will return instead of returning 1 for OK or 0 for Cancel. The meaning of any status value greater than 1 is determined by your application.

Return Values

Type: List

A two-dimensional point that is the (X,Y) location of the dialog box when the user exited it.

Remarks

If you provide a callback for the button whose key is "accept" or "cancel" (usually the OK and Cancel buttons), the callback must call done_dialog explicitly. If it does not, the user can be trapped in the dialog box. If you do not provide an explicit callback for these buttons and use the standard exit buttons, AutoCAD handles them automatically. Also, an explicit AutoLISP action for the "accept" button must specify a status of 1 (or an application-defined value); otherwise, start_dialog returns the default value, 0, which makes it appear as if the dialog box was canceled.

You must call done_dialog from within an action expression or callback function.

Examples

N/A