vlax-remove-cmd (AutoLISP/ActiveX)

Removes a single command or a command group

Supported Platforms: Windows only

Signature

(vlax-remove-cmd global-name)
global-name

Type: String or T

Name of the command, or T. If global-name is T, the whole command group VLC-AppName (for example, VLC-VLIDE) is deleted.

Return Values

Type: T or nil

T, if successful; otherwise nil (for example, the command is not defined).

Remarks

Removes a single command or the whole command group for the current AutoCAD session.

Examples

Remove a command defined with vlax-add-cmd:

(vlax-remove-cmd "hello-autocad")
T

Repeat the vlax-remove-cmd:

(vlax-remove-cmd "hello-autocad")
nil

This time vlax-remove-cmd returns nil, because the specified command does not exist anymore.