setview (AutoLISP)

Establishes a view for a specified viewport

Supported Platforms: Windows and Mac OS

Signature

(setview view_descriptor [vport_id])
view_descriptor

Type: Ename (entity name)

An entity definition list similar to that returned by tblsearch when applied to the VIEW symbol table.

vport_id

Type: Integer

Viewport to receive the new view. If vport_id is 0, the current viewport receives the new view.

You can obtain the vport_id number from the AutoCAD CVPORT system variable.

Return Values

Type: Ename (entity name) or nil

If successful, the setview function returns the view_descriptor.

Examples

N/A