vlax-curve-getPointAtDist (AutoLISP/ActiveX)

Returns the point (in WCS) along a curve at the distance specified by the user

Supported Platforms: Windows only

Signature

(vlax-curve-getPointAtDist curve-obj dist)
curve-obj

Type: VLA-object

The object to be measured.

dist

Type: Real

The distance along the curve from the beginning of the curve to the location of the specified point.

Return Values

Type: List or nil

A 3D point representing a point on the curve, if successful; otherwise nil.

Examples

Assuming that splineObj points to the spline shown in the example for vlax-curve-getDistAtParam, determine the point at a distance of 1.0 from the beginning of the spline:

(vlax-curve-getPointAtDist splineObj 1.0)
(2.24236 2.99005 0.0)