vlax-curve-getPointAtParam (AutoLISP/ActiveX)

Returns the point at the specified parameter value along a curve

Supported Platforms: Windows only

Signature

(vlax-curve-getPointAtParam curve-obj param)
curve-obj

Type: VLA-object

The object to be measured.

param

Type: Integer or Real

A number specifying a parameter on the curve.

Return Values

Type: List or nil

A 3D point representing a point on the curve, if successful; otherwise nil.

Examples

For the following example, assume that splineObj points to the spline shown in the example for vlax-curve-getDistAtParam.

Obtain the start parameter of the curve:

(setq startSpline (vlax-curve-getStartParam splineObj))
0.0

Obtain the end parameter of the curve:

(setq endSpline (vlax-curve-getEndParam splineObj))
17.1546

Determine the point at the parameter midway along the curve:

(vlax-curve-getPointAtParam splineObj
   ( / (- endspline startspline) 2))
(6.71386 2.82748 0.0)