vl-bb-set (AutoLISP)

Sets a variable in the blackboard namespace

Supported Platforms: Windows and Mac OS

Signature

(vl-bb-set 'symbol value)
'symbol

Type: Symbol

A symbol naming the variable to be set.

value

Type: Integer, Real, String, List, Ename (entity name), T, or nil

Any value, except a function.

Return Values

Type: Integer, Real, String, List, Ename (entity name), T, or nil

The value you assigned to symbol.

Examples

(vl-bb-set 'foobar "Root toot toot")
"Root toot toot"

(vl-bb-ref 'foobar)
"Root toot toot"