vl-doc-set (AutoLISP)

Sets the value of a variable in the current document's namespace

Supported Platforms: Windows and Mac OS

Signature

(vl-doc-set 'symbol value)
'symbol

Type: Symbol

A symbol naming a variable.

value

Type: Integer, Real, String, List, Ename (entity name), T, or nil

Any value.

Return Values

Type: Integer, Real, String, List, Ename (entity name), T, or nil

The value set.

Remarks

This function can be used by an application to set the value of a variable that resides in the current document's namespace.

If executed within a document namespace, vl-doc-set is equivalent to set.

Examples

(vl-doc-set 'foobar "Rinky dinky stinky")
"Rinky dinky stinky"