TextInsideAlign Property (ActiveX)

Specifies the position of dimension text inside the extension lines for all dimension types except ordinate.

Supported platforms: Windows only

Signature

VBA:

object.TextInsideAlign
object

Type: Dim3PointAngular, DimAligned, DimAngular, DimArcLength, DimDiametric, DimRadial, DimRadialLarge, DimRotated

The objects this property applies to.

Property Value

Read-only: No

Type: Boolean

Remarks

The initial value for this property is True.

This property is only available when the TextInside property is set to True.

Note: This property overrides the value of the DIMTIH system variable for the given dimension.

Examples

VBA:

Sub Example_TextInsideAlign()
    ' This example creates an aligned dimension in model space and
    ' allows the user to toggle the TextInsideAlign value for the dimension

    Dim dimObj As AcadDimAligned
    Dim point1(0 To 2) As Double, point2(0 To 2) As Double
    Dim location(0 To 2) As Double
    
    ' Define the dimension
    point1(0) = 5: point1(1) = 5: point1(2) = 0
    point2(0) = 5.5: point2(1) = 6: point2(2) = 0
    location(0) = 5: location(1) = 7: location(2) = 0
    
    ' Create an aligned dimension object in model space
    Set dimObj = ThisDrawing.ModelSpace.AddDimAligned(point1, point2, location)
    
    dimObj.TextInside = True    ' The TextInsideAlign property will only work
                                ' when this property is active
    
    ThisDrawing.Application.ZoomAll

Toggle:
    Select Case MsgBox("Press OK to toggle the TextInsideAlign value for this dimension", vbOKCancel)
        Case vbOK
            ' Toggle the TextInsideAlign value for this dimension
            dimObj.TextInsideAlign = Not (dimObj.TextInsideAlign)
            ThisDrawing.Regen acAllViewports
            
            ' Read and display the new dimension TextInsideAlign value
            MsgBox "TextInsideAlign is currently set to: " & dimObj.TextInsideAlign
        
        Case vbCancel
            Exit Sub
    End Select
    
    GoTo Toggle
   
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_TextInsideAlign()
    ;; This example creates an aligned dimension in model space and
    ;; allows the user to toggle the TextInsideAlign value for the dimension
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
    
    ;; Define the dimension
    (setq point1 (vlax-3d-point 5 5 0)
          point2 (vlax-3d-point 5.5 6 0)
          location (vlax-3d-point 5 7 0))
    
    ;; Create an aligned dimension object in model space
    (setq modelSpace (vla-get-ModelSpace doc))
    (setq dimObj (vla-AddDimAligned modelSpace point1 point2 location))
    
    (vla-put-TextInside dimObj :vlax-true)    ;; The TextInsideAlign property will only work
                                              ;; when this property is active
    
    (vla-ZoomAll acadObj)

    ;; Toggle the TextInsideAlign value for this dimension
    (vla-put-TextInsideAlign dimObj (if (= (vla-get-TextInsideAlign dimObj) :vlax-true) :vlax-false :vlax-true))
    (vla-Regen doc acAllViewports)
            
    ;; Read and display the new dimension TextInsideAlign value
    (alert (strcat "TextInsideAlign is currently set to: " (if (= (vla-get-TextInsideAlign dimObj) :vlax-true) "True" "False")))

    ;; Toggle the TextInsideAlign value for this dimension
    (vla-put-TextInsideAlign dimObj (if (= (vla-get-TextInsideAlign dimObj) :vlax-true) :vlax-false :vlax-true))
    (vla-Regen doc acAllViewports)
            
    ;; Read and display the new dimension TextInsideAlign value
    (alert (strcat "TextInsideAlign is currently set to: " (if (= (vla-get-TextInsideAlign dimObj) :vlax-true) "True" "False")))
)